No credit?

Message boards : Number crunching : No credit?
Message board moderation

To post messages, you must log in.

Previous · 1 · 2 · 3 · 4 · 5

AuthorMessage
Profile Rysiu
Project administrator
Project developer
Project tester
Project scientist
Avatar

Send message
Joined: 25 Aug 19
Posts: 407
Credit: 1,228,385
RAC: 211
Poland
Message 274 - Posted: 8 Feb 2020, 18:54:29 UTC

ID: 274 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Dirk Broer

Send message
Joined: 9 Oct 19
Posts: 60
Credit: 2,685,832
RAC: 3,066
British Virgin Islands
Message 288 - Posted: 19 Feb 2020, 1:57:30 UTC

ID: 288 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Saenger

Send message
Joined: 25 Jan 20
Posts: 17
Credit: 177,426
RAC: 318
Germany
Message 291 - Posted: 23 Feb 2020, 13:53:40 UTC - in response to Message 288.  

There has been no stats export since February 8th, 2020

Perhaps any connection with the project prefs, where I can't safe my permission to export stats?
Grüße vom Sänger
ID: 291 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Rysiu
Project administrator
Project developer
Project tester
Project scientist
Avatar

Send message
Joined: 25 Aug 19
Posts: 407
Credit: 1,228,385
RAC: 211
Poland
Message 292 - Posted: 23 Feb 2020, 16:44:02 UTC

Yes. The problem occurred after the database migration. But the database works...

There's probably a bug somewhere...

I'm trying to find the problem.
ID: 292 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Dirk Broer

Send message
Joined: 9 Oct 19
Posts: 60
Credit: 2,685,832
RAC: 3,066
British Virgin Islands
Message 294 - Posted: 24 Feb 2020, 1:31:31 UTC - in response to Message 291.  

There has been no stats export since February 8th, 2020

Perhaps any connection with the project prefs, where I can't safe my permission to export stats?

Because it gives a double database error?
ID: 294 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Sergey Kovalchuk

Send message
Joined: 23 Sep 19
Posts: 59
Credit: 789,745
RAC: 0
Ukraine
Message 295 - Posted: 24 Feb 2020, 7:40:08 UTC - in response to Message 292.  

Yes. The problem occurred after the database migration. But the database works...

There's probably a bug somewhere...

I'm trying to find the problem.

There may be a discrepancy between the database schema version and the server version
You can try to find and run the database update script from the upgrade kit, look for the part where all these bells and whistles with the new policy are added
ID: 295 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Rysiu
Project administrator
Project developer
Project tester
Project scientist
Avatar

Send message
Joined: 25 Aug 19
Posts: 407
Credit: 1,228,385
RAC: 211
Poland
Message 297 - Posted: 24 Feb 2020, 20:57:20 UTC

But why change the version of the database schema with the server version?

The structure of the database remained unchanged.
The structure has not changed. This is the old structure compatible with this server.

Only the location of the database has changed. Now the database is in a dedicated system.

It's a clone of the old database.
ID: 297 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Sergey Kovalchuk

Send message
Joined: 23 Sep 19
Posts: 59
Credit: 789,745
RAC: 0
Ukraine
Message 298 - Posted: 25 Feb 2020, 6:53:13 UTC - in response to Message 297.  

The structure of the database remained unchanged.


all new options that appeared on the server (= WEB interface) must be activated synchronously in the database.

for example, consent to export, agreement with the new policy, choice of applications, number of processors / tasks, separate accounting for applications / subprojects.

all these options activate part of the interface, but they also require support in the database (the presence of the necessary fields in the tables or new tables)

you _must_ change the database so that already activated options work (2 errors in the preference settings). similarly for all new options needed now and in the future
ID: 298 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Rysiu
Project administrator
Project developer
Project tester
Project scientist
Avatar

Send message
Joined: 25 Aug 19
Posts: 407
Credit: 1,228,385
RAC: 211
Poland
Message 299 - Posted: 25 Feb 2020, 19:53:53 UTC

I don't understand much.
I don't understand what options in the database you mean?

I made a 1:1 base dump.
The database is identical.
The database hasn't changed anything.

Only the location of the database has changed (different IP address, different user/password).
The content is the same.

Only the reference address to the database has changed (database content unchanged).
The current database contains all information about the number of processors, etc.
Ohh - I see very old information about my hosts.

Probably the problem is not the lack of information in the database.
The problem is that BOINC server wants to connect to the old database.

All the deamons are working (only some files not working). They see the new database location.
db_dump can't see the new data:

2020-02-25 19:44:12.8122 db_dump starting
Database error: The user specified as a definer ('boincadm'@'localhost') does not exist

db_dump wants to connect to the old database.
Currently there is no database on the localhost!

In the project configuration files there is no longer a database on the localhost and with the boincadm user.
This is a bug in the server.
Probably quite an old bug (maybe in a new version of softu already fixed?).
ID: 299 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Sergey Kovalchuk

Send message
Joined: 23 Sep 19
Posts: 59
Credit: 789,745
RAC: 0
Ukraine
Message 300 - Posted: 26 Feb 2020, 6:43:24 UTC - in response to Message 299.  

I made a 1:1 base dump.
The database is identical.
The database hasn't changed anything.


two new options were activated - activated on the server, but not supported in the database.
the database still remained unchanged, but the server configuration changed.
two new interface options (agreement with the policy and permission to export) cannot find the necessary fields in the database

I’m not sure that these options (primarily the policy) can easily be “cleaned up” on the server to the old state - to match the database.
ID: 300 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Dirk Broer

Send message
Joined: 9 Oct 19
Posts: 60
Credit: 2,685,832
RAC: 3,066
British Virgin Islands
Message 301 - Posted: 26 Feb 2020, 14:21:34 UTC

In my 2nd line helpdesk days I often encountered that DBA's had copied a database and that the copy did not communicate with the rest of the software/database, as the old one did.
This was because each database has an Id for the communication and copying a database results in a new Id for communication, while replicating a database -which was the recommended procedure, but which can take far longer depending on the database size- does not alter that Id. Just my two cents.
ID: 301 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Dirk Broer

Send message
Joined: 9 Oct 19
Posts: 60
Credit: 2,685,832
RAC: 3,066
British Virgin Islands
Message 302 - Posted: 1 Mar 2020, 12:38:06 UTC - in response to Message 295.  

Yes. The problem occurred after the database migration. But the database works...

There's probably a bug somewhere...

I'm trying to find the problem.

There may be a discrepancy between the database schema version and the server version
You can try to find and run the database update script from the upgrade kit, look for the part where all these bells and whistles with the new policy are added

I think Sergey Kovalchuk is on the right track. The various links from within the BOINC manager (e.g. forum, account) are also no longer connecting to iThena, only the main project page does.
ID: 302 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Rysiu
Project administrator
Project developer
Project tester
Project scientist
Avatar

Send message
Joined: 25 Aug 19
Posts: 407
Credit: 1,228,385
RAC: 211
Poland
Message 303 - Posted: 1 Mar 2020, 21:40:12 UTC

Maybe it's about some specific permissions / configuration to the database.
But it seemed unlikely to me.
Any link to the BOINC documentation?

I was looking for information here: https://groups.google.com/a/ssl.berkeley.edu/forum/#!topic/boinc_projects/I8HKtRTPMgA.
ID: 303 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Rysiu
Project administrator
Project developer
Project tester
Project scientist
Avatar

Send message
Joined: 25 Aug 19
Posts: 407
Credit: 1,228,385
RAC: 211
Poland
Message 304 - Posted: 5 Mar 2020, 18:03:33 UTC

Any ideas?
I didn't get any new information on the BOINC mailing list.
ID: 304 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Sergey Kovalchuk

Send message
Joined: 23 Sep 19
Posts: 59
Credit: 789,745
RAC: 0
Ukraine
Message 305 - Posted: 6 Mar 2020, 8:09:57 UTC - in response to Message 302.  

The various links from within the BOINC manager (e.g. forum, account) are also no longer connecting to iThena, only the main project page does.

Something changed on the server last week. IE has stopped working with the site. Chrome works.
Perhaps this is the "Global site tag (gtag.js) - Google Analytics"?
ID: 305 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Sergey Kovalchuk

Send message
Joined: 23 Sep 19
Posts: 59
Credit: 789,745
RAC: 0
Ukraine
Message 306 - Posted: 6 Mar 2020, 8:35:35 UTC - in response to Message 304.  

Any ideas?


only ideas, this is not practice

synchronization of users on different servers is required.
something like ~/rhosts, including for the database.

and delve into the stat dump script - find where the admin name is written there, it can be explicitly inside and not from the server config

if practical
it’s better to ask your colegs directly - they already "stepped on all this rake" ;-)
write Goofyx, Rebirther or Tomáš Brada
may be able to go to the admin Gaia@Home - he is also actively searching for problems with the server
ID: 306 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Rysiu
Project administrator
Project developer
Project tester
Project scientist
Avatar

Send message
Joined: 25 Aug 19
Posts: 407
Credit: 1,228,385
RAC: 211
Poland
Message 307 - Posted: 6 Mar 2020, 12:13:36 UTC

Preference page error fixed: https://root.ithena.net/usr/prefs.php?subset=project

We're waiting for the results...
ID: 307 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Sergey Kovalchuk

Send message
Joined: 23 Sep 19
Posts: 59
Credit: 789,745
RAC: 0
Ukraine
Message 308 - Posted: 6 Mar 2020, 12:51:57 UTC - in response to Message 307.  

not everyone managed to allow the export and get into the last dump.
probably you need to run some extraordinary dumps in order to avoid losing stats on external sites

can at the same time add "run only selected applications"?
in case the new application is launched
ID: 308 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Previous · 1 · 2 · 3 · 4 · 5

Message boards : Number crunching : No credit?

© 2019-2023 iThena. All rights reserved. | Private Policy

Page generated on 8 Jun 2023, 4:44:40 UTC in 0.2409 seconds.