Posts by Vato

1) Message boards : News : New Badges: iThena CNode and iThena PERF - credits points requirements (Message 1014)
Posted 20 Jan 2021 by Profile Vato
Post:
PERF badges seem to be here now!
but not CNode badges?
2) Message boards : Number crunching : Why does my credit not show up on combined BOINC stats websites? (Message 974)
Posted 19 Dec 2020 by Profile Vato
Post:
ithena shows up on free-dc for me...
do your accounts on both projects use the same email address?
3) Message boards : News : iThena CNode (non-beta) badge - badge graphics proposals (Message 743)
Posted 7 Aug 2020 by Profile Vato
Post:
those are nice
well done!
4) Message boards : News : iThena PERF version 1.03 - platforms windows_intelx86 and x86_64-pc-linux-gnu (Message 588)
Posted 6 Jun 2020 by Profile Vato
Post:
this is not a windows specific issue - but it only manifests on PERF app, on both windows and linux
my guess is the WUs generated have a problem, or some of the iperf targets are behaving differently
v1.03 was working fine, with longer runtimes (>30 minutes), but for the last few days is only running for ~3 minutes
unfortunately, this is shorter than the 5 minute timeout on contacting the server
which leads to some periods of no work taking place
5) Message boards : Number crunching : Points/Credit (Message 570)
Posted 23 May 2020 by Profile Vato
Post:
I also see that after some time period of running both, some event stops dual running from continuing.
I have not had to resubmit the form - i just made the client update, after the 5 minute wait after downloading a CNode tasks has expired, and then a PERF tasks downloads.
For some period thereafter, both run and get new tasks happily.
6) Message boards : Number crunching : CNode is out of work (Message 567)
Posted 23 May 2020 by Profile Vato
Post:
Now there is new work.
Must have just being a matter of timing.
7) Message boards : Number crunching : CNode is out of work (Message 566)
Posted 23 May 2020 by Profile Vato
Post:
But perhaps the Server Status page is not accurate?
8) Message boards : Number crunching : CNode is out of work (Message 565)
Posted 23 May 2020 by Profile Vato
Post:
CNode is out of work.
Only PERF is available.
Which means there is nothing for my ARM host to crunch.
9) Message boards : Number crunching : Multi task (Message 414)
Posted 13 Apr 2020 by Profile Vato
Post:
i saw no issues with linux cnode app during the timeframe of the issue with the perf app
it hasn't happened since though
10) Message boards : Number crunching : Multi task (Message 408)
Posted 12 Apr 2020 by Profile Vato
Post:
i had one host get 4 concurrent tasks - similar timeframe as the original post.
the other 2 hosts were running long long tasks which i aborted recently - they both then downloaded only a single task
11) Message boards : News : iThena PERF and Windows platform - first version (Message 359)
Posted 24 Mar 2020 by Profile Vato
Post:
next one just hung again
host is 4141 - you should be able to see the ratio of successes to aborts
have aborted and restarted
12) Message boards : News : iThena PERF and Windows platform - first version (Message 357)
Posted 24 Mar 2020 by Profile Vato
Post:
left it overnight, all 3 hosts hung and had ~8 hours runtime when i next checked
to further test my theory, i've set NNW on the 2 wifi machines, and aborted the 3 hung tasks
so far, the single machine appears to working well
will update later

as far as my environment goes, it's a pretty standard home setup:
some wired machines via a switch to the ISP router
some machines/tablets/phones/TV via Wifi to ISP router
ISP is cable 100Mbps from VirginMedia (Liberty Global UK)
13) Message boards : News : iThena PERF and Windows platform - first version (Message 353)
Posted 23 Mar 2020 by Profile Vato
Post:
Having done a little experimentation...

My current theory is that it is some kind of rate limiting or blocking - either by my ISP, or by the iperf servers (or their upstream ISP)

If I start a WU on all 3 machines at the same time, one of 2 things seems to happen:
1) all 3 hang
or
2) one works, and the other 2 hang - the next WU on the host that worked the first time, tends to hang too.

If I stagger all 3 hosts at ~20 minute intervals, all 3 appear to work.

Just a theory, but more time spent observing this will firm up this theory.

It would still be useful to be able to diagnose the app, to see which phase is hanging.

It would probably be useful to put some kind of timeout on each target and/or on the WU as a whole, though ideally this would need some randomisation to avoid synchronisation.
14) Message boards : News : iThena PERF and Windows platform - first version (Message 351)
Posted 22 Mar 2020 by Profile Vato
Post:
ok, understood
i will endeavour to get timely feedback to you
15) Message boards : News : iThena PERF and Windows platform - first version (Message 349)
Posted 22 Mar 2020 by Profile Vato
Post:
and subsequently, all 3 hosts had got to 4+ hours so i aborted them
so, given that some of them work sometimes, i don't think this is a host issue
the only common factor is my ISP and router
but there are no clues in the slot directory that give me any hint about what triggered the failure
only that at some point in execution, the app stopped updating any files (without logging anything) but continued running, rather than completing or erroring out
16) Message boards : News : iThena PERF and Windows platform - first version (Message 348)
Posted 22 Mar 2020 by Profile Vato
Post:
not Virtualbox VM - BOINC just reports that VB is installed.
So all are native Win10 with same configs, other than IP, and the aforementioned wifi versus wired difference.
17) Message boards : News : iThena PERF and Windows platform - first version (Message 346)
Posted 22 Mar 2020 by Profile Vato
Post:
again the 2 wifi machines worked out well
the wired machine, i just aborted task 8815 at over 4 hours
i didn't spot anything in stderr.txt that stood out
new task on that machine is 10031
18) Message boards : News : iThena PERF and Windows platform - first version (Message 344)
Posted 22 Mar 2020 by Profile Vato
Post:
Cable - 100Mbps - no issues currently visible.
I have 3 machines running PERF at the moment
2 of them (on WiFi) just completed successfully at approx 1 hour
The other one (direct wired) is still ticking upwards at 90 minutes so far - I will leave it to run and see if it ever finishes.
19) Message boards : News : iThena PERF and Windows platform - first version (Message 342)
Posted 22 Mar 2020 by Profile Vato
Post:
after some early successes with shorter WUs, i've not had a single one complete, just runs endlessly - including the new 6xxx WUs
20) Message boards : News : iThena PERF and Windows platform - first version (Message 330)
Posted 21 Mar 2020 by Profile Vato
Post:
so will the expected runtime now be 1-2 hours as well?


Next 20

© 2019-2024 iThena. All rights reserved. | Private Policy

Page generated on 24 May 2024, 20:06:27 UTC in 0.1025 seconds.