Raspberry pi 4 error

Questions and Answers : Unix/Linux : Raspberry pi 4 error
Message board moderation

To post messages, you must log in.

Previous · 1 · 2

AuthorMessage
Dirk Broer

Send message
Joined: 9 Oct 19
Posts: 61
Credit: 3,154,070
RAC: 1,091
British Virgin Islands
Message 100 - Posted: 31 Oct 2019, 19:03:19 UTC
Last modified: 31 Oct 2019, 19:03:38 UTC

ID: 100 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Dirk Broer

Send message
Joined: 9 Oct 19
Posts: 61
Credit: 3,154,070
RAC: 1,091
British Virgin Islands
Message 103 - Posted: 3 Nov 2019, 1:45:28 UTC

Next try:

I edited /lib/systemd/system/boinc-client.service to include the Environment parameter (as the error points to locales).

[Unit]
Description=Berkeley Open Infrastructure Network Computing Client
Documentation=man:boinc(1)
After=network-online.target

[Service]
*Added line to test whether inclusion of the Environment parameter helps
Environment=LC_ALL=C
ProtectHome=true
Type=simple
Nice=10
User=boinc
WorkingDirectory=/var/lib/boinc
ExecStart=/usr/bin/boinc
ExecStop=/usr/bin/boinccmd --quit
ExecReload=/usr/bin/boinccmd --read_cc_config
ExecStopPost=/bin/rm -f lockfile
IOSchedulingClass=idle

Unfortunately I can't test this solution, as it seems the project has run out of WUs...
ID: 103 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Rysiu
Project administrator
Project developer
Project tester
Project scientist
Avatar

Send message
Joined: 25 Aug 19
Posts: 409
Credit: 1,240,185
RAC: 0
Poland
Message 106 - Posted: 3 Nov 2019, 9:49:32 UTC

Tasks should now be available.
Can you check your suggestion on how to solve the problem?
ID: 106 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Dirk Broer

Send message
Joined: 9 Oct 19
Posts: 61
Credit: 3,154,070
RAC: 1,091
British Virgin Islands
Message 108 - Posted: 3 Nov 2019, 11:12:25 UTC - in response to Message 106.  
Last modified: 3 Nov 2019, 11:59:57 UTC

It runs at the moment on a Cortex-A7 Raspberry Pi 2, with normal behaviour of the progress bar (in the past it jumped to 100% within a minute)
It promises to be ready in about 40 minutes from now.

Edit: After 25 minutes it is at 54% and wants another 22 minutes

Finished and validated: https://root.ithena.net/usr/result.php?resultid=101638
ID: 108 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Dirk Broer

Send message
Joined: 9 Oct 19
Posts: 61
Credit: 3,154,070
RAC: 1,091
British Virgin Islands
Message 109 - Posted: 3 Nov 2019, 13:54:35 UTC
Last modified: 3 Nov 2019, 13:55:08 UTC

I can confirm that the 'Environment=LC_ALL=C' solution as described above/below (depending on your sorting) seems to work on the Models 3 and 4 too, WUs are being processsed.
ID: 109 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
fzs600

Send message
Joined: 27 Sep 19
Posts: 19
Credit: 1,079,404
RAC: 543
France
Message 156 - Posted: 16 Nov 2019, 12:48:27 UTC - in response to Message 109.  

with a picture Manjaro raspberry PI 4 it works properly

BCM2835 0.00 0 7.14.2 ARM
BCM2835 [Impl 0x41 Arch 8 Variant 0x0 Part 0xd08 Rev 3]
(4 processeurs) --- Linux Manjaro-ARM
Manjaro ARM Linux [4.19.83-1-MANJARO-ARM|libc 2.29 (GNU libc)]


16 Nov 2019, 11:57:43 UTC 16 Nov 2019, 12:32:59 UTC Terminé et validé 2,094.40 4.50 0.00 iThena CNode v1.17
aarch64-unknown-linux-gnu
ID: 156 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
JugNut

Send message
Joined: 16 Nov 19
Posts: 13
Credit: 27,539,082
RAC: 0
Australia
Message 176 - Posted: 26 Nov 2019, 0:54:24 UTC - in response to Message 156.  

Hi guys is the method mentioned by Dirk still the only way to get Raspberry pi's to run correctly here?
Mine just ran & ran without end until I aborted them.

Looking in the slot directory there was a file called check.dat being constantly created deleted & created again over & over every second.

I'd like to be sure this is still the correct course of action. So I presume you'd have to shut down the boinc client then edit boinc-client.service with Environment=LC_ALL=C is there any other steps involved for those of us new to the world of sudo? (ie: lacking linux skills)

Or is this perhaps a different problem? Any help would be greatly appreciated.
ID: 176 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
JugNut

Send message
Joined: 16 Nov 19
Posts: 13
Credit: 27,539,082
RAC: 0
Australia
Message 197 - Posted: 30 Nov 2019, 23:04:34 UTC - in response to Message 176.  

For those interested when I didn't get a reply from the admin I eventually went ahead and tried it out for myself & the answer is yes this method still works.
Using the information in Dirk Broer's post (message 103) I was able to get two raspberry pi 3's and four Pi 4's working here.

Thanks Dirk.
ID: 197 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
[AF>EDLS]zOU

Send message
Joined: 28 Sep 19
Posts: 10
Credit: 279,940
RAC: 0
France
Message 198 - Posted: 1 Dec 2019, 7:27:12 UTC
Last modified: 1 Dec 2019, 7:28:50 UTC

135UT / 135valids on my RPI :) (v1.17)

No mods: https://root.ithena.net/usr/results.php?hostid=465

FWIW
ID: 198 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
JugNut

Send message
Joined: 16 Nov 19
Posts: 13
Credit: 27,539,082
RAC: 0
Australia
Message 199 - Posted: 1 Dec 2019, 8:35:47 UTC - in response to Message 198.  

As mentioned by Dirk the hack is OS & Region dependant. In other words depending on what region you live in and OS you use you may or may not get this problem. Obviously this fix for those who "do" have the problem described above. The fix in my case worked a treat.
ID: 199 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Dirk Broer

Send message
Joined: 9 Oct 19
Posts: 61
Credit: 3,154,070
RAC: 1,091
British Virgin Islands
Message 886 - Posted: 27 Oct 2020, 1:42:53 UTC

Funny observation:
On my 64-bit OS equipped ARM SBC's the only WU's that are failing appeared to be 32-bit WUs that landed there because i had added <alt_platform> lines to the cc_config.xml in order to run WCG.
I have added the line Environment=LC_ALL=C to /lib/systemd/system/boinc-client.service there now too.
ID: 886 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Dirk Broer

Send message
Joined: 9 Oct 19
Posts: 61
Credit: 3,154,070
RAC: 1,091
British Virgin Islands
Message 887 - Posted: 27 Oct 2020, 9:48:08 UTC - in response to Message 198.  

135UT / 135valids on my RPI :) (v1.17)

No mods: https://root.ithena.net/usr/results.php?hostid=465

FWIW


Just a hunch:
You gave as Country France (or a French-speaking country), with language French, and choose for a French keyboard.
I gave as country the Netherlands, with language English and choose keyboard US -I hate keyboard NL layout, don't have them.
ID: 887 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
0rax

Send message
Joined: 10 Nov 20
Posts: 1
Credit: 72,086
RAC: 0
Message 969 - Posted: 8 Dec 2020, 0:14:30 UTC
Last modified: 8 Dec 2020, 0:20:26 UTC

Just had a similar problem on my Raspberry Pi 3B+ and A+, seems to be correlated to locales and timezone as specified previously.

I was able to find quite a neat solution before stumbling upon this thread, if you are using systemd you can patch them in place (without modifying the original file) by creating a file named `/etc/systemd/system/boinc-client.service.d/environment.conf` with the following content:

[Service]
Environment=LANG=C
Environment=LC_ALL=C
Environment=TZ=UTC


This will force both the language to be the standard "C" locale and the timezone to be set to UTC (I needed all of that for some reason).

You can then just run
systemctl daemon-reload
systemctl restart boinc-client
and you should be able to run iThena WU fine.

It still kinda seems weird to me that I had to patch this system as I have a system set to UTC with the default en_us.UTF-8 locale set but whatever everything seems to work fine with that now.

If I may Dirk, I am currently in the process of moving some of my PIs to ARM64, do you have any input on how running arm32 and arm64 WU on the same host has been so far, any gotchas ? I'm thinking about running Universe@Home (arm32), WCG and LHC@Home on some of them.
ID: 969 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Dirk Broer

Send message
Joined: 9 Oct 19
Posts: 61
Credit: 3,154,070
RAC: 1,091
British Virgin Islands
Message 1163 - Posted: 27 May 2021, 19:38:00 UTC - in response to Message 969.  

If I may Dirk, I am currently in the process of moving some of my PIs to ARM64, do you have any input on how running arm32 and arm64 WU on the same host has been so far, any gotchas ? I'm thinking about running Universe@Home (arm32), WCG and LHC@Home on some of them.


The gotchas:
After adding to the cc_config.xml these lines:
<options>
   <alt_platform>arm-unknown-linux-gnueabihf</alt_platform>
   <alt_platform>armv7l-unknown-linux-gnueabihf</alt_platform>
</options>

and
sudo dpkg --add-architecture armhf
sudo apt update --fix-missing
sudo apt dist-upgrade
sudo apt install libc6:armhf libstdc++6:armhf zlib1g:armhf libfuse2:armhf

to be sure 32-bit libs are there when needed and, voilá: Boinc starts getting work for 32-bit apps.

Optional
Because I was unhappy with the memory assigned to the GPU in the case of a Jetson Nano (a mere 99MB) when using the default 5GB swapdisk I installed and configured ZRAM via
sudo apt install zram-config

and rebooted
Jetson-Nano2GB
Starting BOINC client version 7.9.3 for aarch64-unknown-linux-gnu *so no need to have this as alternate platform*
log flags: file_xfer, sched_ops, task
Libraries: libcurl/7.58.0 OpenSSL/1.1.1 zlib/1.2.11 libidn2/2.0.4 libpsl/0.19.1 (+libidn2/2.0.4) nghttp2/1.30.0 librtmp/2.3
Data directory: /var/lib/boinc-client
CUDA: NVIDIA GPU 0: NVIDIA Tegra X1 (driver version unknown, CUDA version 10.2, compute capability 5.3, 1979MB, 1343MB available, 236 GFLOPS peak) *CUDA! and enough RAM!**
OpenCL CPU: pthread-cortex-a57 (OpenCL driver vendor: The pocl project, driver version 1.1, device version OpenCL 1.2 pocl HSTR: pthread-aarch64-unknown-linux-gnu-GENERIC)
[libc detection] gathered: 2.27, Ubuntu GLIBC 2.27-3ubuntu1.4
Host name: Jetson-Nano2GB
Processor: 4 ARM ARMv8 Processor rev 1 (v8l) [Impl 0x41 Arch 8 Variant 0x1 Part 0xd07 Rev 1]
Processor features: fp asimd evtstrm aes pmull sha1 sha2 crc32
OS: Linux Ubuntu: Ubuntu 18.04.5 LTS [4.9.201-tegra|libc 2.27 (Ubuntu GLIBC 2.27-3ubuntu1.4)]
Memory: 1.93 GB physical, 4.97 GB virtual *ZRAM can deliver enough GB's here too*
Disk: 58.41 GB total, 12.05 GB free *This from a 64GB SD card and a somewhat bloated kernel -installed Debian Science, ALL*
ID: 1163 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Previous · 1 · 2

Questions and Answers : Unix/Linux : Raspberry pi 4 error

© 2019-2024 iThena. All rights reserved. | Private Policy

Page generated on 24 Jun 2024, 9:22:50 UTC in 0.4361 seconds.