iThena PERF and Windows platform - first version

Message boards : News : iThena PERF and Windows platform - first version
Message board moderation

To post messages, you must log in.

Previous · 1 · 2 · 3 · Next

AuthorMessage
Bok

Send message
Joined: 23 Sep 19
Posts: 10
Credit: 648
RAC: 41
Message 336 - Posted: 21 Mar 2020, 22:48:20 UTC

I've completed 18 PERF tasks, but all showing zero credits also.
ID: 336 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Rysiu
Project administrator
Project developer
Project tester
Project scientist
Avatar

Send message
Joined: 25 Aug 19
Posts: 149
Credit: 0
RAC: 0
Message 337 - Posted: 21 Mar 2020, 23:06:39 UTC

There is still the end of the tasks (~100) with badly set credits.

I'm about to generate more tasks for the night (2 credits per task).

We'll check the progress in the morning.
ID: 337 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
KPX

Send message
Joined: 17 Oct 19
Posts: 6
Credit: 398
RAC: 21
Message 338 - Posted: 21 Mar 2020, 23:31:50 UTC - in response to Message 337.  

Could we get credit for all the previous tasks as well? Many thanks...
ID: 338 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Dingo

Send message
Joined: 16 Nov 19
Posts: 4
Credit: 11,428
RAC: 711
Message 339 - Posted: 21 Mar 2020, 23:42:02 UTC

I have over 800 returned with zero credit. I thought the last work on Linux was bad but getting zero for work you process is not what I expected.

I hope you are going to fix this so that all the Valid zero credit tasks get credit or you will lose a lot of users I am sure.
ID: 339 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Rysiu
Project administrator
Project developer
Project tester
Project scientist
Avatar

Send message
Joined: 25 Aug 19
Posts: 149
Credit: 0
RAC: 0
Message 340 - Posted: 21 Mar 2020, 23:57:31 UTC

WUs with numbers in the name above 6000 should have 2 credits per WU.

The first such tasks are in progress.

I will count correct tasks according to the methodology 2 credits per WU.

Do not kill me if there are any errors/bugs! ;)
I'm going to bed! ;)
ID: 340 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
mmonnin

Send message
Joined: 23 Sep 19
Posts: 7
Credit: 510
RAC: 32
Message 341 - Posted: 22 Mar 2020, 1:41:23 UTC

Windows OP.

From 0.00135709 average in Linux to 2. 736x more credit. A bit odd.
ID: 341 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Vato
Avatar

Send message
Joined: 23 Sep 19
Posts: 15
Credit: 708
RAC: 43
Message 342 - Posted: 22 Mar 2020, 9:36:38 UTC

after some early successes with shorter WUs, i've not had a single one complete, just runs endlessly - including the new 6xxx WUs
ID: 342 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Rysiu
Project administrator
Project developer
Project tester
Project scientist
Avatar

Send message
Joined: 25 Aug 19
Posts: 149
Credit: 0
RAC: 0
Message 343 - Posted: 22 Mar 2020, 9:40:09 UTC - in response to Message 342.  

after some early successes with shorter WUs, i've not had a single one complete, just runs endlessly - including the new 6xxx WUs

What is your network connection?
What provider? Cable, wireless?
ID: 343 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Vato
Avatar

Send message
Joined: 23 Sep 19
Posts: 15
Credit: 708
RAC: 43
Message 344 - Posted: 22 Mar 2020, 10:48:03 UTC - in response to Message 343.  

Cable - 100Mbps - no issues currently visible.
I have 3 machines running PERF at the moment
2 of them (on WiFi) just completed successfully at approx 1 hour
The other one (direct wired) is still ticking upwards at 90 minutes so far - I will leave it to run and see if it ever finishes.
ID: 344 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
mmonnin

Send message
Joined: 23 Sep 19
Posts: 7
Credit: 510
RAC: 32
Message 345 - Posted: 22 Mar 2020, 12:07:51 UTC

6xxx have been all successful for me.
ID: 345 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Vato
Avatar

Send message
Joined: 23 Sep 19
Posts: 15
Credit: 708
RAC: 43
Message 346 - Posted: 22 Mar 2020, 13:26:44 UTC

again the 2 wifi machines worked out well
the wired machine, i just aborted task 8815 at over 4 hours
i didn't spot anything in stderr.txt that stood out
new task on that machine is 10031
ID: 346 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Rysiu
Project administrator
Project developer
Project tester
Project scientist
Avatar

Send message
Joined: 25 Aug 19
Posts: 149
Credit: 0
RAC: 0
Message 347 - Posted: 22 Mar 2020, 14:26:14 UTC

I see...
It must be some system or network problem.

You use Virtualbox everywhere.
You have the same network config on all three VMs?
ID: 347 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Vato
Avatar

Send message
Joined: 23 Sep 19
Posts: 15
Credit: 708
RAC: 43
Message 348 - Posted: 22 Mar 2020, 14:43:21 UTC - in response to Message 347.  

not Virtualbox VM - BOINC just reports that VB is installed.
So all are native Win10 with same configs, other than IP, and the aforementioned wifi versus wired difference.
ID: 348 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Vato
Avatar

Send message
Joined: 23 Sep 19
Posts: 15
Credit: 708
RAC: 43
Message 349 - Posted: 22 Mar 2020, 18:58:22 UTC - in response to Message 348.  

and subsequently, all 3 hosts had got to 4+ hours so i aborted them
so, given that some of them work sometimes, i don't think this is a host issue
the only common factor is my ISP and router
but there are no clues in the slot directory that give me any hint about what triggered the failure
only that at some point in execution, the app stopped updating any files (without logging anything) but continued running, rather than completing or erroring out
ID: 349 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Rysiu
Project administrator
Project developer
Project tester
Project scientist
Avatar

Send message
Joined: 25 Aug 19
Posts: 149
Credit: 0
RAC: 0
Message 350 - Posted: 22 Mar 2020, 19:46:22 UTC

A critical problem in this version of the application is the lack of accurate diagnostic information.
In the new week I will add a new version of the application.
Until then, however, we will not come up with too much.

It is possible to perform a local procedure of testing possible errors.
If I have some time, tomorrow I will describe the possible procedure.
ID: 350 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Vato
Avatar

Send message
Joined: 23 Sep 19
Posts: 15
Credit: 708
RAC: 43
Message 351 - Posted: 22 Mar 2020, 20:35:02 UTC - in response to Message 350.  

ok, understood
i will endeavour to get timely feedback to you
ID: 351 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Vato
Avatar

Send message
Joined: 23 Sep 19
Posts: 15
Credit: 708
RAC: 43
Message 353 - Posted: 23 Mar 2020, 23:22:05 UTC - in response to Message 351.  

Having done a little experimentation...

My current theory is that it is some kind of rate limiting or blocking - either by my ISP, or by the iperf servers (or their upstream ISP)

If I start a WU on all 3 machines at the same time, one of 2 things seems to happen:
1) all 3 hang
or
2) one works, and the other 2 hang - the next WU on the host that worked the first time, tends to hang too.

If I stagger all 3 hosts at ~20 minute intervals, all 3 appear to work.

Just a theory, but more time spent observing this will firm up this theory.

It would still be useful to be able to diagnose the app, to see which phase is hanging.

It would probably be useful to put some kind of timeout on each target and/or on the WU as a whole, though ideally this would need some randomisation to avoid synchronisation.
ID: 353 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Rysiu
Project administrator
Project developer
Project tester
Project scientist
Avatar

Send message
Joined: 25 Aug 19
Posts: 149
Credit: 0
RAC: 0
Message 354 - Posted: 23 Mar 2020, 23:29:58 UTC

Currently there is (should be) a limit of 30 seconds per jump between measurements / servers.

Theoretically, if the iperf server is busy with other measurements, it should return the information "I'm busy" and the program should go to the next measurement / server.

Perhaps it is blocking your ISP something extra?
I observe that a lot of users have no problems.
However sometimes these problems appear.
I also do not have a full picture of the situation yet.
ID: 354 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Rysiu
Project administrator
Project developer
Project tester
Project scientist
Avatar

Send message
Joined: 25 Aug 19
Posts: 149
Credit: 0
RAC: 0
Message 355 - Posted: 23 Mar 2020, 23:44:50 UTC

What is the average network usage characteristics (current tasks) per WU and per hour?

I know it depends on the connection of the network client and several other factors, but how does it look on average?
ID: 355 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Vato
Avatar

Send message
Joined: 23 Sep 19
Posts: 15
Credit: 708
RAC: 43
Message 357 - Posted: 24 Mar 2020, 9:57:25 UTC - in response to Message 355.  

left it overnight, all 3 hosts hung and had ~8 hours runtime when i next checked
to further test my theory, i've set NNW on the 2 wifi machines, and aborted the 3 hung tasks
so far, the single machine appears to working well
will update later

as far as my environment goes, it's a pretty standard home setup:
some wired machines via a switch to the ISP router
some machines/tablets/phones/TV via Wifi to ISP router
ISP is cable 100Mbps from VirginMedia (Liberty Global UK)
ID: 357 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Previous · 1 · 2 · 3 · Next

Message boards : News : iThena PERF and Windows platform - first version

© 2020 iThena. All rights reserved.

Page generated on 3 Apr 2020, 1:24:07 UTC in 0.0802 seconds.